当前位置: 移动技术网 > 移动技术>移动开发>IOS > 1042 Shuffling Machine (20分)

1042 Shuffling Machine (20分)

2020年07月13日  | 移动技术网移动技术  | 我要评论

测试地址:

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K(≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题意:有 54 张牌,开始时有固定的顺序,输入交换的次数和一组交换顺序,输出交换后的牌的顺序。

比如 S3, H5, C1, D13 and J2. 输入洗牌顺序 4, 2, 5, 3, 1,

下标 1 2 3 4 5
开始牌的顺序 S3 H5 C1 D13 J2
洗牌顺序 4 2 5 3 1
交换(下标与洗牌顺序) D13 H5 J2 C1 S3
交换后的下标 1 2 3 4 5
交换后牌的顺序 D13 H5 J2 C1 S3
再次洗牌 4 2 5 3 1
再次交换 C1 H5 S3 J2

D13

再次交换后的下标 1 2 3 4 5
再次交换后牌的顺序 C1 H5 S3 J2

D13

思路:

有 54 张牌,输入交换次数和 54 张牌的洗牌顺序,使用 start 和 end 数组保存每一次变换的开始顺序和结束顺序(以1~54的编号存储), 后根据编号与扑克牌字母数字的对应关系输出 end 数组

c++代码:

#include<cstdio>
int main(){
	int n;
	scanf("%d", &n);
	int start[55], end[55], scan[55];
	for(int i = 1; i < 55; i++){
		scanf("%d", &scan[i]);
		end[i] = i;
	}
	while(n--){
		for(int i = 1; i < 55; i++){
			start[i] = end[i];
		}
		for(int j = 1; j < 55; j++){
			end[scan[j]] = start[j];
		}
	}
	char c[6] = {"SHCDJ"};
	for(int i = 1; i < 55; i++){
		end[i] = end[i]-1;
		if(i != 1) printf(" ");
		printf("%c%d", c[end[i]/13], end[i]%13+1);
	}
	return 0;
} 

 

本文地址:https://blog.csdn.net/Struggle_0/article/details/107295565

如对本文有疑问, 点击进行留言回复!!

相关文章:

验证码:
移动技术网