当前位置: 移动技术网 > IT编程>数据库>Access > Cow Bowling(POJ-3176)

Cow Bowling(POJ-3176)

2020年08月14日  | 移动技术网IT编程  | 我要评论
POJ - 3176 传送门DescriptionThe cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0…99), though, and line up in a standard bowling-pin-like triangle like this: 7388&nbs.

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0…99), though, and line up in a standard bowling-pin-like triangle like this:
  7
 3  8
 8  1  0
 2  7  4  4
 4  5  2  6  5
Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.
Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N
Lines 2…N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

题意

给你一个数塔,从上往下走,只能选择向下或者向下的右边,问所走过的数字之和最大值

分析

从底部向上走,当前点 + 走下去的两个点中的最大一个数字,当走到(1,1)的位置时获得的状态最优
状态转移方程:dp[i][j] = map[i][j] + max(dp[i+1][j] , dp[i+1][j+1])


Code

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e4;
int dp[maxn][maxn];
int map[maxn][maxn];
int sum = 0;
int main()
{
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	int n;
	cin>>n;
	for(int i = 1 ; i <= n ; i++)
	{
		for(int j = 1 ; j <= i ; j++)
		{
			cin>>map[i][j];
		}
	}
	for(int i = n ; i >= 1 ; i--)
	{
		for(int j = 1 ; j <= i ; j++)
		{
			dp[i][j] = map[i][j] + max(dp[i+1][j],dp[i+1][j+1]);
		}
	}
	cout<<dp[1][1]<<endl;
	return 0;
}

本文地址:https://blog.csdn.net/weixin_46425926/article/details/107983613

如您对本文有疑问或者有任何想说的,请点击进行留言回复,万千网友为您解惑!

相关文章:

验证码:
移动技术网