当前位置: 移动技术网 > IT编程>开发语言>C/C++ > 【TOJ 2406】Power Strings(kmp找最多重复子串)

【TOJ 2406】Power Strings(kmp找最多重复子串)

2018年05月03日  | 移动技术网IT编程  | 我要评论

奔跑吧兄弟关晓彤,大人帝国反击战,魔法小恶魔第二部

描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

输入

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

For each s you should print the largest n such that s = a^n for some string a.

样例输入

abcd
aaaa
ababab
.

样例输出

1
4
3

提示

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题解

就是找一个字符串中最多重复的子串,求出它重复的次数

#include<bits/stdc++.h>
using namespace std;
const int M=1e6;
char s[M+5];
int next[M+5];
void GetNext(char s[],int len)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(s[i]==s[j]||j==-1)
        {
            j++;
            i++;
            next[i]=j;
        }
        else j=next[j];
    }
}
int main()
{
    while(scanf("%s",s)!=EOF,s[0]!='.')
    {
        int len=strlen(s);
        GetNext(s,len);
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else printf("1\n");
    }
    return 0;
}

 

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网