当前位置: 移动技术网 > IT编程>开发语言>C/C++ > [AtCoder][ARC081]Coloring Dominoes 题解

[AtCoder][ARC081]Coloring Dominoes 题解

2018年07月28日  | 移动技术网IT编程  | 我要评论

信件结尾,认私生女竟是假冒,斗智天使路

Coloring Dominoes

时间限制: 1 Sec 内存限制: 128 MB 
原题链接 

题目描述

We have a board with a 2×N grid. Snuke covered the board with N dominoes without overlaps. Here, a domino can cover a 1×2 or 2×1 square. 
Then, Snuke decided to paint these dominoes using three colors: red, cyan and green. Two dominoes that are adjacent by side should be painted by different colors. Here, it is not always necessary to use all three colors. 
Find the number of such ways to paint the dominoes, modulo 1000000007. 
The arrangement of the dominoes is given to you as two strings S1 and S2 in the following manner: 
Each domino is represented by a different English letter (lowercase or uppercase). 
The j-th character in Si represents the domino that occupies the square at the i-th row from the top and j-th column from the left.

Constraints 
1≤N≤52 
|S1|=|S2|=N 
S1 and S2 consist of lowercase and uppercase English letters. 
S1 and S2 represent a valid arrangement of dominoes.

输入

Input is given from Standard Input in the following format: 

S1 
S2

输出

Print the number of such ways to paint the dominoes, modulo 1000000007.

样例输入


aab 
ccb

样例输出

6

题解

由于区域的宽度只有2,且每个多米诺骨牌也只能占据连续的两格,因此对于任意一列而言,只有两种摆法,竖着1个或者横着两个。 
因此,通过数学规律可以计算出涂色的可能性。

代码

#include <iostream>
#include <string>

#define ull unsigned long long
#define MO 1000000007

using namespace std;
int n, k, c;
string s1, s2;
ull ans;

int main() {
    ios::sync_with_stdio(false);
    cin.tie(nullptr);
    cout.tie(nullptr);

    cin >> n >> s1 >> s2;
    if (s1[0] == s2[0])c = 1, ans = 3; else c = 2, ans = 6;
    k = c;
    while (k < n) {
        if (s1[k] == s2[k]) {
            ans *= 3 - c;
            c = 1;
        } else {
            ans *= c + 1;
            c = 2;//Skip 2
        }
        k += c;
        ans %= MO;
    }
    cout << ans;
    return 0;
}

 

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网