当前位置: 移动技术网 > IT编程>开发语言>C/C++ > poj-2488 a knight's journey(搜索题)

poj-2488 a knight's journey(搜索题)

2018年08月19日  | 移动技术网IT编程  | 我要评论

黄道益官网,玉血晗霜玉帘,开心宝贝之美食大作战

time limit1000 ms

memory limit65536 kb

 

background 
the knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. whenever a knight moves, it is two squares in one direction and one square perpendicular to this. the world of a knight is the chessboard he is living on. our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. can you help this adventurous knight to make travel plans? 

problem 
find a path such that the knight visits every square once. the knight can start and end on any square of the board.

input

the input begins with a positive integer n in the first line. the following lines contain n test cases. each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. this represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. these are the first q letters of the latin alphabet: a, . . .

output

the output for every scenario begins with a line containing "scenario #i:", where i is the number of the scenario starting at 1. then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. the path should be given on a single line by concatenating the names of the visited squares. each square name consists of a capital letter followed by a number. 
if no such path exist, you should output impossible on a single line.

sample input

3
1 1
2 3
4 3

sample output

scenario #1:
a1

scenario #2:
impossible

scenario #3:
a1b3c1a2b4c2a3b1c3a4b2c4


题意:骑士走棋盘,要求把所有的各自都要走一遍,并且要输出走棋盘的格子
题解:dfs搜索吧,注意每次可以搜索的时候都要把步数加一,当步数等于格子数时就可以了
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<stack>
using namespace std;
#define pi 3.14159265358979323846264338327950


int path[100][2],vis[100][100],p,q,cnt;
bool flag;
int dx[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int dy[8] = {-2, -2, -1, -1, 1, 1, 2, 2};

bool judge(int x,int y)
{
    if(x<=p && x>=1 && y<=q && y>=1 && !vis[x][y] )
        return true;
    return false;
}
void dfs(int r,int c,int step)
{
    if (flag == false)
    {
        path[step][0]=r;
        path[step][1]=c;
    }
        if(step==p*q)
    {
        flag=true;
        return ;
    }
    for(int i=0;i<8;i++)
    {
        int nx=r+dx[i];
        int ny=c+dy[i];
        if(judge(nx,ny))
        {
            vis[nx][ny]=1;
            dfs(nx,ny,step+1);
            vis[nx][ny]=0;
        }
    }
}
int main()
{
    int i,t,cas=0;
    cin>>t;
    while(t--)
    {
        flag=0;
        cin>>p>>q;
        memset(vis,0,sizeof(vis));
        vis[1][1]=1;
        dfs(1,1,1);
        printf("scenario #%d:\n",++cas);
        if(flag)
        {
            for(i=1;i<=p*q;i++)
            {
                printf("%c%d",path[i][1]-1+'a',path[i][0]);
            }
        }
        else
            printf("impossible");
        printf("\n");
        if(t!=0)
            printf("\n");
    }
}

 

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网