当前位置: 移动技术网 > IT编程>开发语言>C/C++ > 4 Values whose Sum is 0 POJ - 2785

4 Values whose Sum is 0 POJ - 2785

2018年08月21日  | 移动技术网IT编程  | 我要评论

五星大饭店演员表,哈尔滨公交查询,金童卡修下载

4 values whose sum is 0
time limit: 15000ms   memory limit: 228000k
total submissions: 29243   accepted: 8887
case time limit: 5000ms

description

the sum problem can be formulated as follows: given four lists a, b, c, d of integer values, compute how many quadruplet (a, b, c, d ) ∈ a x b x c x d are such that a + b + c + d = 0 . in the following, we assume that all lists have the same size n . 

input

the first line of the input file contains the size of the lists n (this value can be as large as 4000). we then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to a, b, c and d . 

output

for each input file, your program has to write the number quadruplets whose sum is zero. 

sample input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

sample output

5

hint

sample explanation: indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30). 
 
题意:abcd四个数列,每个数列抽一个数字,使得和为0,问一共有几组。当一个数列中有多个相同的数字时,把他们作为不同的数字看待。
思路:直接爆搜肯定会超时,将它们对半分成ab和cd再考虑就可以解决。比如在ab中取出a,b后,cd中要取出-a-b,因此先把cd中所有取数字的情况n*n种给纪录下来,然后排序,用二分查找次数。
 
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<set>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define eps 1e-10
typedef long long ll;
const int maxn = 4002;
const int mod = 1e9 + 7;
int gcd(int a, int b) {
    if (b == 0) return a;  return gcd(b, a % b);
}

int n;
int a[maxn],b[maxn],c[maxn],d[maxn];
int cd[maxn*maxn];

void solve()
{
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            cd[i*n+j]=c[i]+d[j];
        }
    sort(cd,cd+n*n);
    ll res=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            int ab=-(a[i]+b[j]);
            res+=upper_bound(cd,cd+n*n,ab)-lower_bound(cd,cd+n*n,ab);
        }
    cout<<res<<endl;
}
int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
    
    solve();
}

 

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网