当前位置: 移动技术网 > IT编程>开发语言>C/C++ > (杭电1406)完数

(杭电1406)完数

2018年12月03日  | 移动技术网IT编程  | 我要评论

色系军团邪恶漫画集,世界风景名胜图片,小房型

题目描述
there is a collection of n activities e={1,2,..,n}, each of which requires the same resource, such as
a lecture venue, etc., and only one activity at a time use this resource. each activity i has a start
time of si and an end time of fi and si<fi. if the activity i is selected, it occupies resources within
the time interval [si,fi). if the interval [si,fi) does not intersect the interval [sj,fj), then the activity i is
said to be compatible with the activity j. that is, when fi<=sj or fj<=si, the activity i is compatible
with the activity j . choose the largest collection of activities that are compatible with each other.
输入格式
the first line is an integer n;
the next n line, two integers per line, si and fi.
输出格式
excluding mutual and compatible maximum active number.
样例输入1
4
1 3
4 6
2 5
1 7
样例输出1
2

数据范围与提示
1<=n<=1000

 

这道题解法与杭电今年暑假不ac解法相同,采用贪心法

代码实例

#include<stdio.h>

struct huodong
{
    int begin;
    int end;
} j[1002];

int main()
{
    int n,i,j,sum,temp;
    sum = 1;
    scanf("%d",&n);
    for(i=0; i<n; i++)
        scanf("%d %d",&j[i].begin,&j[i].end);
    for(i=0; i<n-1; i++)
    {
        for(j=0; j<n-i-1; j++)
        {
            if(j[j].end>j[j+1].end)
            {
                temp = j[j].end;
                j[j].end = j[j+1].end;
                j[j+1].end = temp;

                temp = j[j].begin;
                j[j].begin = j[j+1].begin;
                j[j+1].begin = temp;
            }
        }
    }
    temp = j[0].end;
    for(i=1; i<n; i++)
    {
        if(j[i].begin>=temp)
        {
            sum++;
            temp = j[i].end;
        }
    }
    printf("%d\n",sum);
    return 0;
}

 

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网