当前位置: 移动技术网 > IT编程>开发语言>C/C++ > ACM1001:Sum Problem

ACM1001:Sum Problem

2019年03月11日  | 移动技术网IT编程  | 我要评论

退魔启示录,ca4428,如影相随

problem description
in this problem, your task is to calculate sum(n) = 1 + 2 + 3 + ... + n.
 
input
the input will consist of a series of integers n, one integer per line.
 
output
for each case, output sum(n) in one line, followed by a blank line. you may assume the result will be in
the range of 32-bit signed integer.
 
sample input
1
100
 
sample output
1
 
5050
 ------------------------------------------------------------------------------------------------------------------
sn = n*(n+1)/2
把两个相同的自然数列逆序相加
2sn=1+n + 2+(n-1) + 3+(n-2) + ... n+1
=n+1 +n+1 + ... +n+1
=n*(n+1)
sn=n*(n+1)/2
另,
m到n的自然数之和:smn=(n-m+1)/2*(m+n)
(n>m)
smn=sn-s(m-1)
=n*(n+1)/2 -(m-1)*(m-1+1)/2
={n*(n+1) - m(m-1)}/2
={n*(n+1) - mn + m(1-m) + mn }/2
={n*(n-m+1)+ m(1+ n-m)}/2
=(n+m)(n-m+1)/2
注意:虽然题目说sum不会大于32位,但是n*(n+1)会大于32位。
 
#include <stdio.h>
#include <stdlib.h>

int main()
{
    long long n;
    //freopen("f:\\input.txt", "r", stdin);
    while (scanf("%lld", &n) != eof)
    {
        printf("%lld\n\n", n * (n + 1) / 2);
    }
    //freopen("con", "r", stdin);
    //system("pause");
    return 0;
}

  

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网