当前位置: 移动技术网 > IT编程>开发语言>C/C++ > hdu2612 Find a way BFS

hdu2612 Find a way BFS

2018年03月27日  | 移动技术网IT编程  | 我要评论

cctv1天气预报直播,8090个人门户,天龙之寻道

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20320    Accepted Submission(s): 6575

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 
Sample Input
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 
Sample Output
66 88 66

题意:

Y和M要在最短的时间到KFC(@)吃饭,# - - -墙,.- -可行路

思路:

进行两次BFS,分别求他们到KFC的最短时间,最后求他们和的最小值即可。

注意点:

1.---对标记数组的初始化

2--每一步是11分钟,不是1分钟。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#define INF 0x3f3f3f3f
#define N 250
using namespace std;
char mp[N][N];
int vis[N][N];
int stepY[N][N],stepM[N][N];//分别是Y和M从起点到点(i,j)的时间
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int n,m;
struct node{
int x,y;
};
int judge(int x,int y){
if(x>=0&&x<n&&y>=0&&y<m)
    return 1;
    return 0;
}
void BFS(node s,int step[][N]){
queue<node>q;
node now,next;
vis[s.x][s.y]=1;
q.push(s);
while(!q.empty()){
    now=q.front();
    q.pop();
    for(int i=0;i<4;i++){
        next.x=now.x+dir[i][0];
        next.y=now.y+dir[i][1];
        if(judge(next.x,next.y)&&!vis[next.x][next.y]&&mp[next.x][next.y]!='#'){
            vis[next.x][next.y]=1;
            step[next.x][next.y]=step[now.x][now.y]+1;
            q.push(next);
        }
    }
}
return ;
}
int main(){
node jiY,jiM;
int min1;
while(~scanf("%d%d",&n,&m)){
    min1=INF;
    memset(stepY,0,sizeof(stepM));
    memset(stepM,0,sizeof(stepM));
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            cin>>mp[i][j];
            if(mp[i][j]=='Y'){//Y的起始位置
                jiY.x=i;
                jiY.y=j;
            }
            if(mp[i][j]=='M'){//M的起始位置
                jiM.x=i;
                jiM.y=j;
            }
        }
    }
    memset(vis,0,sizeof(vis));
    BFS(jiY,stepY);
    memset(vis,0,sizeof(vis));//注意初始化
    BFS(jiM,stepM);
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            if(mp[i][j]=='@'&&stepY[i][j]!=0&&stepM[i][j]!=0){//两个人都可以到达KFC
                min1=min(min1,stepY[i][j]+stepM[i][j]);
            }
        }
    }
    printf("%d\n",min1*11);
}
return 0;
}

 

如对本文有疑问,请在下面进行留言讨论,广大热心网友会与你互动!! 点击进行留言回复

相关文章:

验证码:
移动技术网